Tazer Mini Install

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
Is anyone else having trouble removing the two SGW cable above the OBD2 connector? I assume I have to press-in a tab on each connector and pull at the same time to unplug the SGW cables. My Mitts just don't fit in that small space and I'm afraid of breaking the cable assembly or my hand...
 

Pigpen

New member
Founding Member
Jeep 392 of the Month
Joined
Feb 12, 2021
Messages
13
Reaction score
19
Location
Denver
Yeah, they’re tough to reach. There is a little more space if you remove the plastic dash panel under the steering wheel
 

BenLandry

Active member
Founding Member
Joined
Mar 1, 2021
Messages
206
Reaction score
234
Location
Conroe, TX
Is anyone else having trouble removing the two SGW cable above the OBD2 connector? I assume I have to press-in a tab on each connector and pull at the same time to unplug the SGW cables. My Mitts just don't fit in that small space and I'm afraid of breaking the cable assembly or my hand...
Did you buy the extension? If you did then you won’t have to struggle like this again. But the first time is a bloody knuckle bitch for sure.
 
OP
D

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
Yeah, they’re tough to reach. There is a little more space if you remove the plastic dash panel under the steering wheel
I've done that....I must not understand the mechanics of the plug locking mechanism....A visual would help...
 
OP
D

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
Did you buy the extension? If you did then you won’t have to struggle like this again. But the first time is a bloody knuckle bitch for sure.
Yes I've got it on order....getting 37's tomorrow....I guess the 392 will have to put up with the wrong size until I get the damn plug removed....
 

EBYCREEK

New member
Joined
Jul 2, 2021
Messages
20
Reaction score
16
Location
Eagle, CO
Current Rides
2021 392 Wrangler
I was able to push in on the tab and wiggle it back and forth as I pulled down.
 
OP
D

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
I was able to push in on the tab and wiggle it back and forth as I pulled down.
I think I'm going to give up for now....I've even tried right angle needle nose pliers pulling on cable at same time pressing in tab to no avail.....
 

Smess

Active member
Founding Member
Joined
Jun 19, 2021
Messages
166
Reaction score
127
Location
SOFL
Current Rides
2021 Jeep 392, 2021 Jeep Gladiator, 1982 Jeep J10
yes the tab that has to be pushed in is on the far side facing away from you. Best thing is to get a flash light and see what you are up against or get someone with small hands. when you add the extension you will never have to do it again.

I used a flat head and pushed on the tab and on the far side and used my thumb on the other side to pull at the same time. pain in the ass but you dont want to pull on the wires like you want to because if the wires break you are screwed.

Get a flashlight and person with little hands. I dont have big hands and mine were all tore up
 
OP
D

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
yes the tab that has to be pushed in is on the far side facing away from you. Best thing is to get a flash light and see what you are up against or get someone with small hands. when you add the extension you will never have to do it again.

I used a flat head and pushed on the tab and on the far side and used my thumb on the other side to pull at the same time. pain in the ass but you dont want to pull on the wires like you want to because if the wires break you are screwed.

Get a flashlight and person with little hands. I dont have big hands and mine were all tore up
Thanks for the reply....I finally got the $%&#* connectors removed....what did it was a squirt of PTFE dry lube on each connector. Installed the SGW extension cable and now my NEXT PROBLEM is getting a Tazer that works. I got the 1st one on Amazon...followed the instructions...updated the software...it would not link up to the Jeep and I noticed the LED was not coming on when plugged in the SGW cable...returned it. Got a second on from Z Automotive....same problem. Ian at Z automotive sent me another one...should get that one today. I can't believe there are 2 bad units....everything seems to work on the Jeep...so the cable should be good...I hope...
 

Smess

Active member
Founding Member
Joined
Jun 19, 2021
Messages
166
Reaction score
127
Location
SOFL
Current Rides
2021 Jeep 392, 2021 Jeep Gladiator, 1982 Jeep J10
two that didnt work does sound a little strange. I am very familiar with all aspects of the Tazer mini, I had issues due to the instructions being a little ambiguous and the owner gave me personal training for a lack of better words, if you need help let me know I would be happy to help you.

I have a 392 with 37's and a Tazer and a Pedal Commander and a highly modified diesel gladiator running the same and both are perfect now.
 
OP
D

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
two that didnt work does sound a little strange. I am very familiar with all aspects of the Tazer mini, I had issues due to the instructions being a little ambiguous and the owner gave me personal training for a lack of better words, if you need help let me know I would be happy to help you.

I have a 392 with 37's and a Tazer and a Pedal Commander and a highly modified diesel gladiator running the same and both are perfect now.
Well I got the third Tazer....I could not believe this...the large connector went into the Tazer OK....but the smaller connector did not go all the way in....checked for bent pins...everything OK....it does not click in...no amount of force will seat it....The connectors go into the extender cable....you can hear the click when seated....at this point I'm pretty well disappointed in the whole &%*$ thing....
 

Smess

Active member
Founding Member
Joined
Jun 19, 2021
Messages
166
Reaction score
127
Location
SOFL
Current Rides
2021 Jeep 392, 2021 Jeep Gladiator, 1982 Jeep J10
Ok you clearly have explained that your vision is not the best? Seriously I am not being a dick, you are describing what happens when you have it turned the wrong way. There are four possibilities, it has to be right. I have installed 7 or 8 of them in the last 5 months and not one problem other than programming questions but my vision is going and I used a very powerful light and reading glasses.

What model PC dis u get. There are a few that are pretty similar, it has to be exacf
 

Smess

Active member
Founding Member
Joined
Jun 19, 2021
Messages
166
Reaction score
127
Location
SOFL
Current Rides
2021 Jeep 392, 2021 Jeep Gladiator, 1982 Jeep J10
Take a pic of it and I can help you
 
OP
D

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
Take a pic of it and I can help you
The tazer box says Z-TZR-JLM....I'm using a PC to update the firmware....version 11.3.1...serial DACC...092821d1v2...
I didn't think you could insert the connector in a different orientation....I'll have to try it again tomorrow afternoon....we have company now...thanks so much for the help....later....Don
 
OP
D

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
Image 1 shows the SGW connectors plugged into the extender cable. Image 2 shows the faces of the SGW connectors. Image 3 shows the pins on Tazer mini. Image 4 shows how the smaller SGW connector does not seat all the way into the Tazer...pressing very hard in the connector does not seat it. When I put the Jeep in "run" mode on the ignition, the Nav screen does not turn on. This did not happen on the first two Tazers.....not having much luck with these things....
20211009_100732_resized.jpg
20211009_100923_resized.jpg
20211009_101235_resized.jpg
Inked20211009_101046_resized_LI.jpg
 
OP
D

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
Image 1 shows the SGW connectors plugged into the extender cable. Image 2 shows the faces of the SGW connectors. Image 3 shows the pins on Tazer mini. Image 4 shows how the smaller SGW connector does not seat all the way into the Tazer...pressing very hard in the connector does not seat it. When I put the Jeep in "run" mode on the ignition, the Nav screen does not turn on. This did not happen on the first two Tazers.....not having much luck with these things....View attachment 1600View attachment 1601View attachment 1602View attachment 1603
The reason the smaller connector did not seat all the way in is because one of the connector "rails was deformed....cleaned it up with sharp knife and small screwdriver blade....it now seats in correctly....
The LED light does not turn on when the ignition is in the "run" position....and the device will not "marry"...
 
OP
D

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
Ok you clearly have explained that your vision is not the best? Seriously I am not being a dick, you are describing what happens when you have it turned the wrong way. There are four possibilities, it has to be right. I have installed 7 or 8 of them in the last 5 months and not one problem other than programming questions but my vision is going and I used a very powerful light and reading glasses.

What model PC dis u get. There are a few that are pretty similar, it has to be exacf
Are you saying "what model PC did you get"?....aside from that, the led on the Tazer is not coming on when plugged in to the SGW cables and not sure why...
 

Smess

Active member
Founding Member
Joined
Jun 19, 2021
Messages
166
Reaction score
127
Location
SOFL
Current Rides
2021 Jeep 392, 2021 Jeep Gladiator, 1982 Jeep J10
Are you saying "what model PC did you get"?....aside from that, the led on the Tazer is not coming on when plugged in to the SGW cables and not sure why...
Please ignore that, I was on another thread talking about the Tazer and pc together. sorry
 

Smess

Active member
Founding Member
Joined
Jun 19, 2021
Messages
166
Reaction score
127
Location
SOFL
Current Rides
2021 Jeep 392, 2021 Jeep Gladiator, 1982 Jeep J10
something does not look right in that pic, here is mine
 

Attachments

  • IMG_0019.PNG
    IMG_0019.PNG
    1.2 MB · Views: 27
OP
D

dgerb

Member
Founding Member
Joined
Jun 11, 2021
Messages
95
Reaction score
69
Location
Sedona, Arizona
Current Rides
2021 392
something does not look right in that pic, here is mine
This is a photo of my setup...the wires look the same. I didn't push the connector on the left all the way in this time...even if I do the LED doesn't turn on. For some reason the Tazer is not being powered on and can't communicate with the Jeep computer. I wonder what the pinout of the SGW connectors are. I assume if the Jeep seems to work correctly that the SGW cable is OK.
 

Attachments

  • pic 1.jpg
    pic 1.jpg
    99.3 KB · Views: 16
Last edited:
Top