Failure to Start Problems

mikebarrett10

New member
Joined
Apr 26, 2021
Messages
3
Reaction score
4
Location
Camas Washington
Current Rides
2021 Jeep Rubicon 392
Hi there. I have a new 392 with 4k miles on it. Since the first week it occasionally does not want to start. All the power is on but when pushing the button it does not turn over the engine. I have to play with it (pushing the start button and brake and in and out of gear, etc... whatever it takes) for about a minute or 2 before it decides to start.

I took it into the dealer for a recall notice I received that was supposed to fix the problem. The dealer said it was a weak or loose grounding issue on the starter and that it was fixed. It was not fixed.

Has anyone else experienced this problem? Any suggestions (besides the obvious of "take it back to the dealer")!
Thanks so much!
 

byhumba

Well-known member
Founding Member
Joined
Apr 7, 2021
Messages
344
Reaction score
307
Location
SoCal
Make sure all fuses are seated properly. A lot of first builds were having electrical problems. My fuses were not all seated tight. It was the first thing I checked when it arrived.
 
OP
mikebarrett10

mikebarrett10

New member
Joined
Apr 26, 2021
Messages
3
Reaction score
4
Location
Camas Washington
Current Rides
2021 Jeep Rubicon 392
Make sure all fuses are seated properly. A lot of first builds were having electrical problems. My fuses were not all seated tight. It was the first thing I checked when it arrived.
Will do. Thanks!
 
Top