Exhaust rattle....

veddersbetter

Well-known member
Joined
Nov 15, 2021
Messages
225
Reaction score
241
Location
Thomson IL
Current Rides
2021 HB 392XR (sold) 2024 Anvil 392
Has anyone had an exhaust rattle on acceleration? Mine started this today and reminds me of the dreaded junk heatshield I had to tear off the last 3 JKs.
I checked that and checked to make sure everything is tight... hoping it's not a baffle in the active exhaust... trying to avoid the dealer like the plague.
 
Has anyone had an exhaust rattle on acceleration? Mine started this today and reminds me of the dreaded junk heatshield I had to tear off the last 3 JKs.
I checked that and checked to make sure everything is tight... hoping it's not a baffle in the active exhaust... trying to avoid the dealer like the plague.

Here's a video from the inside... couldn't hear it when mounted outside.

 
Does it rattle in quiet mode?

Have you adjusted your muffler so it does not lean to the left like so may seem to from the factory?
 
Does it rattle in quiet mode?

Have you adjusted your muffler so it does not lean to the left like so may seem to from the factory?

-It doesn't rattle in quiet mode (until I'm in it enough to open the baffles)
-Have not adjusted the muffler... it arrived level so I havent touched it.
-it doesn't start making the noise until its up close to normal operating temp
-and I haven't changed anything to create that noise... I was out on a drive and about an hour into it ... randomly just started and hasn't gone away
 
Rattles can be difficult!. Have you gotten under the Jeep while the exhaust is cool and grabbed/shaken the exhaust to see if it touches somewhere? There is give in an exhaust system so maybe you can duplicate the spot and make adjustments?

I don't like taking a vehicle to a dealer to have monkeys work on it but sometimes its necessary. They should definitely look for a noise like this as long as they can duplicate it. I had my GMC in to the dealer for other warranty work and they were able to fix the rattle I had in my rear seat only when it was folded up. It had drove me crazy for months up until then.
 
Rattles can be difficult!. Have you gotten under the Jeep while the exhaust is cool and grabbed/shaken the exhaust to see if it touches somewhere? There is give in an exhaust system so maybe you can duplicate the spot and make adjustments?

I don't like taking a vehicle to a dealer to have monkeys work on it but sometimes its necessary. They should definitely look for a noise like this as long as they can duplicate it. I had my GMC in to the dealer for other warranty work and they were able to fix the rattle I had in my rear seat only when it was folded up. It had drove me crazy for months up until then.
I agree. Sometimes the noise originates as high as at the engine joints, but you hear it at the muffler.

I also agree with getting under the Jeep when cold and shake the whole exhaust system to try pin-pointing the cause.
 
Rattles can be difficult!. Have you gotten under the Jeep while the exhaust is cool and grabbed/shaken the exhaust to see if it touches somewhere? There is give in an exhaust system so maybe you can duplicate the spot and make adjustments?

I don't like taking a vehicle to a dealer to have monkeys work on it but sometimes its necessary. They should definitely look for a noise like this as long as they can duplicate it. I had my GMC in to the dealer for other warranty work and they were able to fix the rattle I had in my rear seat only when it was folded up. It had drove me crazy for months up until then.

Thanks guys..
I did crawl under it yesterday and wiggled and shook everything I could ...everything is tight. Went under today with a 15mm socket and tightened everything on the exhaust.. nothing was loose at all.

I noticed yesterday (after I got frustrated and paused for a while) that it only started doing it once it was close to normal operating temp... may try to mount the gopro completely under the Jeep and see what I find.
 
Mine just started doing this as well; only when accelerating briskly. I was wondering if it was the baffle or maybe a heat shield or something as well. I'll try to locate it this weekend.
 
Thanks guys..
I did crawl under it yesterday and wiggled and shook everything I could ...everything is tight. Went under today with a 15mm socket and tightened everything on the exhaust.. nothing was loose at all.

I noticed yesterday (after I got frustrated and paused for a while) that it only started doing it once it was close to normal operating temp... may try to mount the gopro completely under the Jeep and see what I find.

Mine just started doing this as well; only when accelerating briskly. I was wondering if it was the baffle or maybe a heat shield or something as well. I'll try to locate it this weekend.

Outside temp dropped about 30 degrees and I havent heard it again. .. drove for about an hour... Nothin. Has me "baffled"
 
Mine just started doing this as well; only when accelerating briskly. I was wondering if it was the baffle or maybe a heat shield or something as well. I'll try to locate it this weekend.

Ever find anything?
 
You know when I put my soft top on I got a weird rattle under heavy load but it quit before I could troubleshoot it.
 
I don’t think mine is coming from these tabs or the rear glass. It’s dead quiet in all driving on all surfaces until I stomp on the go pedal. It really sounds like it’s exhaust. I’ll look a little more
 
I don’t think mine is coming from these tabs or the rear glass. It’s dead quiet in all driving on all surfaces until I stomp on the go pedal. It really sounds like it’s exhaust. I’ll look a little more

Thats the same as mine... dead quiet until Im on the gas. It could be the SOT and it just doesnt like that exact resonance.
Haven't been able to duplicate the issue since I posted this however. Only thing I did was torque down all the exhaust connections (none were loose at all) and remove my trail rail attachments. I wouldnt think those would make that noise but maybe its possible?
 
More word on rattle. So the part throttle rattle came back. Seemed to be under moderate load at 3k rpm. I thought it was coming from soft top bow or something like that. Put my daughter in the back to troubleshoot it and it went away. Even after she got out of the back. Thinking it was something in the storage area that her weight squished. ..... Weird. But at least if it comes back will be easy to sort out. Nothing serious, just minor annoyance. Doesn't do it at WOT. :)
 
Back
Top