Drive shaft harmonic balancer Fail

Fellow 392'rs,
The harmonic balancer came off my front drive shaft
20210802_113905.jpg
recently. I tied it back to get home. Took it to the dealer and they have yet to get updates parts info for the 392 to identify the parts and/or fix. They removed the ring and allowed me to drive it without it for now. Has anyone else had this problem or know how I can get this resolved quickly?
Thanks!
 
Ouch! Feel for ‘ya man. :(
 
Fellow 392'rs,
The harmonic balancer came off my front drive shaftView attachment 924 recently. I tied it back to get home. Took it to the dealer and they have yet to get updates parts info for the 392 to identify the parts and/or fix. They removed the ring and allowed me to drive it without it for now. Has anyone else had this problem or know how I can get this resolved quickly?
Thanks!
Did you ever get this figured out? I just had the same issue with that ring coming loose while I was out riding.
 
Hey sorry to hear that. How did you know it came off? Loud noises from underneath? How does it drive with it off? Is it just a greater chance for vibration issues? Not too versed on this part as you can tell. Hope you get it fixed soon. Also, if you don’t mind me asking what mileage?
 
Hey sorry to hear that. How did you know it came off? Loud noises from underneath? How does it drive with it off? Is it just a greater chance for vibration issues? Not too versed on this part as you can tell. Hope you get it fixed soon. Also, if you don’t mind me asking what mileage?
You just hear a clinking. Nothing noticable about the ride.
 
Fellow 392'rs,
The harmonic balancer came off my front drive shaftView attachment 924 recently. I tied it back to get home. Took it to the dealer and they have yet to get updates parts info for the 392 to identify the parts and/or fix. They removed the ring and allowed me to drive it without it for now. Has anyone else had this problem or know how I can get this resolved quickly?
Thanks!I

Fellow 392'rs,
The harmonic balancer came off my front drive shaftView attachment 924 recently. I tied it back to get home. Took it to the dealer and they have yet to get updates parts info for the 392 to identify the parts and/or fix. They removed the ring and allowed me to drive it without it for now. Has anyone else had this problem or know how I can get this resolved quickly?
Thanks!
I currently have the exact same failure on my 392 at ~9000 miles. I found the harmonic balancer rattling around loose on the front drive shaft making a sound similar to a dragging a chain. I tied mine back with zip ties to get home, albeit with a bit of vibration at highway speed. I'm going to get the dealer to have a look this afternoon.
 
I currently have the exact same failure on my 392 at ~9000 miles. I found the harmonic balancer rattling around loose on the front drive shaft making a sound similar to a dragging a chain. I tied mine back with zip ties to get home, albeit with a bit of vibration at highway speed. I'm going to get the dealer to have a look this afternoon.
Any updates? This just happened to me yesterday and I’m scratching my head. Going to the dealer today.
 
The dealer is covering it under warranty, however the part is backordered with no estimated availability date.
 
This happened to me while off-roading. I tied it off, to the Front differential, and cut it off when I got home. I have aftermarket driveshafts so never bothered discussing it with the dealer.

That was more than a year ago. No issues and never looked back.
 
No, I went with a local shop. I did Evo Coilovers, air bumps, Antirock, and a bunch of RockJock stuff. This was in 2021 and I was the first 392 to use the Evo Coilovers… so not much was really known at the time.

here are a couple pictures. One old and one new
83E7F9BC-C7DF-4723-A29E-9101F8DF713C.jpeg

5BA25CAD-5E4C-41A5-9307-6F68F4030439.jpeg
 
That part is called the axle damper part number 5038902AA its listed in the housing image with the vin part number off in the search. I was just with my mechanic and he didn't even know that was a part on my jeep until he pulled my drive shaft off. he went right into the parts guy and they took 20 mins just to finally figure out the correct part. It not on the build list for the 392's. Like it was an after thought.
 
That part is called the axle damper part number 5038902AA its listed in the housing image with the vin part number off in the search. I was just with my mechanic and he didn't even know that was a part on my jeep until he pulled my drive shaft off. he went right into the parts guy and they took 20 mins just to finally figure out the correct part. It not on the build list for the 392's. Like it was an after thought.
How about a pic please
 
This happened to me while off-roading. I tied it off, to the Front differential, and cut it off when I got home. I have aftermarket driveshafts so never bothered discussing it with the dealer.

That was more than a year ago. No issues and never looked back.
It looks like the OP has aftermarket drive shafts as well. I'm glad to hear the dealer didn't raise a stink about this and agreed to cover the repair/replacement of the balancer.
 
Back
Top