Arrived looking like $@!£

Truckdriver

Well-known member
Founding Member
Joined
Jan 11, 2021
Messages
88
Reaction score
52
Location
Gulf Breeze Florida
Curious if any of you other guys have had any issues with your jeep when it arrives. Mine arrived with a sticker on the door said that it was randomly chosen to be test driven for 60 miles...
Got it home, started going three things and found the carpet on the driver side was extremely dirty (won’t even vacuum out) and the front end was absolutely filthy underneath, even with some rust already starting.
Photos attached.
Have to wonder if mine was one of the ones that went to Moab???
 

Attachments

  • C27152BD-0B6B-4E0A-84CF-396347EE3297.jpeg
    C27152BD-0B6B-4E0A-84CF-396347EE3297.jpeg
    166.5 KB · Views: 654
  • 97656F69-4128-4217-BA4B-F0E0ABD26010.jpeg
    97656F69-4128-4217-BA4B-F0E0ABD26010.jpeg
    77.9 KB · Views: 469
  • 95098B14-B0C7-4B52-8942-4C5D8EA01A25.jpeg
    95098B14-B0C7-4B52-8942-4C5D8EA01A25.jpeg
    147.5 KB · Views: 459
  • 861F4A43-ABB4-4ACA-B4EC-99602B9E1882.jpeg
    861F4A43-ABB4-4ACA-B4EC-99602B9E1882.jpeg
    108.5 KB · Views: 460
Have you read this one at the JL forum?
 
Sorry about your experience. How can this be avoided? Should we decline to take it home if it is in this state? There are laws protecting dealers calling a vehicle with 200 miles "brand new." Ugh
 
Curious if any of you other guys have had any issues with your jeep when it arrives. Mine arrived with a sticker on the door said that it was randomly chosen to be test driven for 60 miles...
Got it home, started going three things and found the carpet on the driver side was extremely dirty (won’t even vacuum out) and the front end was absolutely filthy underneath, even with some rust already starting.
Photos attached.
Have to wonder if mine was one of the ones that went to Moab???
Was your 392 ever in that "in-storage" status that took months to get to the dealer?
 
Have you read this one at the JL forum?
YES!!!!! Exactly the same!!! Rust all over and mud caked underneath! Engine bay looks like it’s about 5 years old!
Honestly, I’m thinking about returning it!
 

Attachments

  • 84B0284A-B53A-42C0-BDA6-63BDB48BB388.jpeg
    84B0284A-B53A-42C0-BDA6-63BDB48BB388.jpeg
    93.2 KB · Views: 346
  • CFAF850E-1F8E-46A5-AFAE-975CA14994E9.jpeg
    CFAF850E-1F8E-46A5-AFAE-975CA14994E9.jpeg
    157.6 KB · Views: 350
  • FB09B8CD-A9F7-4FD5-BA42-DA48C38CD8BD.jpeg
    FB09B8CD-A9F7-4FD5-BA42-DA48C38CD8BD.jpeg
    106.5 KB · Views: 356
  • 5ECBBDF5-5EB1-47FA-8F60-F34D0914FAFD.jpeg
    5ECBBDF5-5EB1-47FA-8F60-F34D0914FAFD.jpeg
    117.5 KB · Views: 349
  • 5D6FC30E-2910-4D9D-B674-F67B19338C70.jpeg
    5D6FC30E-2910-4D9D-B674-F67B19338C70.jpeg
    104.8 KB · Views: 358
  • 97543403-FC1C-4F44-B369-6D7166149BC1.jpeg
    97543403-FC1C-4F44-B369-6D7166149BC1.jpeg
    125.2 KB · Views: 350
Have you read this one at the JL forum?
Just signed up there too, thanks!
 
YES!!!!! Exactly the same!!! Rust all over and mud caked underneath! Engine bay looks like it’s about 5 years old!
Honestly, I’m thinking about returning it!
Damn! Sorry again. I hope Jeep is made aware of this. It will depend on the numbers affected. Did your dealer reps say anything about it? Seems the guy at JL forum is working with the dealer to see how they can fix this.
 
Sorry about your experience. How can this be avoided? Should we decline to take it home if it is in this state? There are laws protecting dealers calling a vehicle with 200 miles "brand new." Ugh
Good question....
Shoulda crawled under it at the dealer but I think all of our expectations are that a NEW and HIGH DOLLAR car should be just that!!
 
Damn! Sorry again. I hope Jeep is made aware of this. It will depend on the numbers affected. Did your dealer reps say anything about it? Seems the guy at JL forum is working with the dealer to see how they can fix this.
Thanks...yea, it’s just WRONG!!!
I’ll keep y’all posted how this pans out...
 
Curious if any of you other guys have had any issues with your jeep when it arrives. Mine arrived with a sticker on the door said that it was randomly chosen to be test driven for 60 miles...
Got it home, started going three things and found the carpet on the driver side was extremely dirty (won’t even vacuum out) and the front end was absolutely filthy underneath, even with some rust already starting.
Photos attached.
Have to wonder if mine was one of the ones that went to Moab???
58 Miles on mine, so someone was doing a lot of Quality Assurance........The undercarriage is definitely dirty and it was more than highway miles, but other than some significant road spray, can't say it was abused.
 
58 Miles on mine, so someone was doing a lot of Quality Assurance........The undercarriage is definitely dirty and it was more than highway miles, but other than some significant road spray, can't say it was abused.
Hmmm!! to all of the above, input from others?
 
Curious if any of you other guys have had any issues with your jeep when it arrives. Mine arrived with a sticker on the door said that it was randomly chosen to be test driven for 60 miles...
Got it home, started going three things and found the carpet on the driver side was extremely dirty (won’t even vacuum out) and the front end was absolutely filthy underneath, even with some rust already starting.
Photos attached.
Have to wonder if mine was one of the ones that went to Moab???

Wow, that's terrible - I would certainly have some choice words with the dealer about that.
 
Ours showed up really dirty underneath and the tires really dirty inside and out with 50 miles on it.
 
Ours showed up really dirty underneath and the tires really dirty inside and out with 50 miles on it.
Was yours ever in the "in-storage" status? Were you one of the early ordes?
 
Mine had 29 miles on it, and was pristine inside and out - the only thing out of place was an extra plastic cover for the rear seat belt mount that was stuck underneath the carpet in front of the back seat. I had the dealership put new tires on it before I picked it up (35" BFG MTs) so I can't speak to original tire condition.
 
Mine had 29 miles on it, and was pristine inside and out - the only thing out of place was an extra plastic cover for the rear seat belt mount that was stuck underneath the carpet in front of the back seat. I had the dealership put new tires on it before I picked it up (35" BFG MTs) so I can't speak to original tire condition.
does the spare tire fit okay on the stock mount?
 
Back
Top